Xero outage affecting invoice payments

Incident Report for Agileware

Resolved

Xero have confirmed services are operational again and integrations have been checked, confirmed OK.
Posted Oct 22, 2025 - 10:27 AEDT

Update

Continuing to monitor the AWS outage impacting Xero
Posted Oct 21, 2025 - 09:39 AEDT

Monitoring

Monitoring the AWS outage impacting Xero
Posted Oct 21, 2025 - 09:38 AEDT

Investigating

Xero have reported an outage which is attributed to AWS, for more details see https://status.xero.com/incidents/8q1vxrlwpkcp
Posted Oct 21, 2025 - 09:38 AEDT
This incident affected: Sales/Accounts Team and Third Party Providers.